Unable to connect OPC UA Compliance Test Tool with Server. | Miscellaneous | Forum

Avatar
Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
Lost password?
sp_Feed sp_PrintTopic sp_TopicIcon
Unable to connect OPC UA Compliance Test Tool with Server.
Avatar
Arunkumar H
Member
Members
Forum Posts: 3
Member Since:
02/18/2021
sp_UserOfflineSmall Offline
1
02/18/2021 - 10:25
sp_Permalink sp_Print sp_EditHistory

Connection Setup:

ABB PLC(AC500 - PM5630-2ETH) <-----> ABB Automation Builder <------> OPC UA Compliance Test Tool
192.168.204.7                                     DesktopIP: 192.168.204.3              Installed in Same Desktop(IP: 192.168.204.3)

Steps Followed:

1. ABB PLC- PM5630-2ETH connected with ABB Automation Builder Gateway and it is communicating fine.
2. Open OPC uaExpert and add  the server(URL: opc.tcp://192.168.204.7:4840, Security Policy: None)
3. Able to add the device successfully.
4. Open 'OPC UA Compliance Test Tool'.
5. Created new project(File -> New Project)[ Project Type: Server Standard Project, Enter ProjectName and Select Project Directory]
6. Enter Server and Endpoint URL(Eg: opc.tcp://192.168.204.7:4840) and Security as None.
7. Configure Nodeid and Add the Trust certificate to Server.
8. Click 'Confirmance Unit' and Choose ' Security None' test cases and Execute.

Observation:
1. OPCUA CTT is not communicating with Server and giving the following Error message.
Output:

Trace: UaChannelPrivate::connect(): SecureChannel_Connect(url=opc.tcp://PM5630-2ETH:4840, TransportProfileUri=https://opcfoundation.org/UA-Profile/Transport/uatcp-uasc-uabinary,
ClientCertificate=PKI/CA/certs/ctt_appT.der, ClientPrivateKey=PKI/CA/private/ctt_appT.pem, ServerCertificate=ToDo: Print Server Certificate Details.,
RequestedSecurityPolicyUri=https://opcfoundation.org/UA/SecurityPolicy#None,
RequestedLifetime=0, MessageSecurityMode=1, AuditEntryId=)

Result:

OpenSecureChannel( MessageSecurityMode: None; RequestedSecurityPolicyUri: https://opcfoundation.org/UA/SecurityPolicy#None
); Result = Stack_BadHostUnknown (0xa0060000)

 

There is a mismatch of the configured ServerUrl (opc.tcp://192.168.204.7:4840) in the CTT Settings and the returned EndpointUrl
(opc.tcp://PM5630-2ETH:4840) in the GetEndpoints. Please validate configuration.

 

Can you please help me to resolve this issue. Thanks in advance.

Forum Timezone: America/Phoenix
Most Users Ever Online: 202
Currently Online:
Guest(s) 5
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Forum Stats:
Groups: 2
Forums: 9
Topics: 919
Posts: 2854