Reference Client (UA.-.NETStandard-master) is BadNotConnected | OPC UA Implementation: Stacks, Tools, and Samples | Forum

Avatar
Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
Lost password?
sp_Feed sp_PrintTopic sp_TopicIcon
Reference Client (UA.-.NETStandard-master) is BadNotConnected
Avatar
PLCBeckhoff
New Member
Members
Forum Posts: 1
Member Since:
10/07/2020
sp_UserOfflineSmall Offline
1
10/15/2020 - 01:16
sp_Permalink sp_Print sp_EditHistory

Hello Everybody!

I have a question that I already asked on the GitHub forum and stackoverflow forum. Unfortunately no one could help me in the two forums. Maybe someone here has had a similar problem before. 

If I do get an answer in the GitHub forum or stackoverflow forum, I'll name it here. My GitHubPost can be found under the following link:

https://github.com/OPCFoundati.....ssues/1139

https://stackoverflow.com/ques.....tconnected

I will still copy the post from the GitHub forum here if the link no longer works at some point.

I downloaded the OPC UA standard project from github (https://github.com/OPCFoundati.....ETStandard). I would like to use the Reference Client there to access a Beckhoff PLC (server). To do this, I opened the project in VS2017 and set the Reference Client as the startup project. Then I started the project with F5. The following window opened:

MFE1o.pngImage Enlarger

If I now specify the IP address and the port of my PLC (as shown above) and then click on "Connect", the client sometimes establishes a connection to the PLC and sometimes I get the following error message:

njGBF.pngImage Enlarger

In about 80% of the cases there is this error message and the client does not connect to the server. In about 20% of the cases a connection to the server is established and I can read and write variables from the server. I didn't change the program and it seems completely arbitrary when the connection can be established and when not. Has anyone ever had a similar problem?

I am using the current versions of VS2017, Windows 10 and OPC UA project.

Many thanks in advance.

Forum Timezone: America/Phoenix
Most Users Ever Online: 202
Currently Online:
Guest(s) 12
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Forum Stats:
Groups: 2
Forums: 9
Topics: 764
Posts: 2249